Support Forums
Plain Excel XLS File Report and HDV Export Issue

When you try to do a "Plain Excel XLS File" report, it fails with the error "Unable to generate report. Invalid data source."

You can also get a similar response when you try to use the print wizard on the Historical Data Viewer.

It appears this is being caused by changes to the Microsoft JET drivers in an October update. The new JET drivers can be found here for 2010 -

https://www.microsoft.com/en-in/download/details.aspx?id=13255

And here for 2016 -

https://www.microsoft.com/en-us/download/details.aspx?id=54920&751be11f-ede8-5a0c-058c-2ee190a24fa6=True&e6b34bbe-475b-1abd-2c51-b5034bcdd6d2=True&fa43d42b-25b5-4a42-fe9b-1634f450f5ee=True&40ddd5bd-f9e7-49a6-3526-f86656931a02=True

Download and install the JET drivers and then, in the main VTScada installation folder, find the file called Excel.dsn and modify the EXCEL.DSN for the following fields as shown...

DRIVER=Microsoft Excel Driver (.xls, .xlsx, .xlsm, .xlsb)
FIL=MS Excel

We cannot distribute the JET files ourselves so we are limited in how to correct this.

If you need to do this, please let us know if it works or not. Email us at support@trihedral.com with the VTScada version and the Excel/Office version you are using.

When you try to do a "Plain Excel XLS File" report, it fails with the error "Unable to generate report. Invalid data source." You can also get a similar response when you try to use the print wizard on the Historical Data Viewer. It appears this is being caused by changes to the Microsoft JET drivers in an October update. The new JET drivers can be found here for 2010 - https://www.microsoft.com/en-in/download/details.aspx?id=13255 And here for 2016 - https://www.microsoft.com/en-us/download/details.aspx?id=54920&751be11f-ede8-5a0c-058c-2ee190a24fa6=True&e6b34bbe-475b-1abd-2c51-b5034bcdd6d2=True&fa43d42b-25b5-4a42-fe9b-1634f450f5ee=True&40ddd5bd-f9e7-49a6-3526-f86656931a02=True Download and install the JET drivers and then, in the main VTScada installation folder, find the file called Excel.dsn and modify the EXCEL.DSN for the following fields as shown... DRIVER=Microsoft Excel Driver (*.xls, *.xlsx, *.xlsm, *.xlsb) FIL=MS Excel We cannot distribute the JET files ourselves so we are limited in how to correct this. If you need to do this, please let us know if it works or not. Email us at support@trihedral.com with the VTScada version and the Excel/Office version you are using.

Doug Spurrell

edited Nov 13 '17 at 3:47 pm

Minor pedantic note, the newer drivers are called ACE, or Access Database Engine.

It's the older, "in-the-box" JET drivers that have been broken\disabled by MS.

Minor pedantic note, the newer drivers are called ACE, or Access Database Engine. It's the older, "in-the-box" JET drivers that have been broken\disabled by MS.

Software Developer with Trihedral

Microsoft seem to have fixed the issue in the November monthly updates, more information here.

To use, install the required update and revert any changes made to the Excel.DSN file. For reference the original contents of the file are:

[ODBC]                               
DRIVER=Microsoft Excel Driver (*.xls)
ReadOnly=0                           
UserCommitSync=Yes                   
Threads=3                            
SafeTransactions=0                   
PageTimeout=5                        
MaxScanRows=8                        
MaxBufferSize=65536                  
ImplicitCommitSync=Yes               
FIL=excel 5.0                        
DriverId=790
Microsoft seem to have fixed the issue in the November monthly updates, more information [here](https://blogs.msdn.microsoft.com/dataaccesstechnologies/2017/10/18/unexpected-error-from-external-database-driver-1-microsoft-jet-database-engine-after-applying-october-security-updates/). To use, install the required update and revert any changes made to the Excel.DSN file. For reference the original contents of the file are: ```` [ODBC] DRIVER=Microsoft Excel Driver (*.xls) ReadOnly=0 UserCommitSync=Yes Threads=3 SafeTransactions=0 PageTimeout=5 MaxScanRows=8 MaxBufferSize=65536 ImplicitCommitSync=Yes FIL=excel 5.0 DriverId=790 ````

Software Developer with Trihedral

Problem solved on windows 7 [x64] with office 2010 [x32] by installing Jet drivers after the windows updates had been applied.

Problem solved on windows 7 [x64] with office 2010 [x32] by installing Jet drivers after the windows updates had been applied.

Century Control Systems, Inc. www.centurycontrolsystems-inc.com

150
4
3
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft