Support Forums
Mismatch of modbus TCP/IP communictaion
1

We are testing the VT Scada Light. I am trying to connect it with a energy measurement system using Modbus over TCP/IP directly from PC.

I created the tag using 'TCP IP Port' -> 'Modbus Compatible Device' -> 'Analog Input' and didn´t get the communication.

Followed the basic configuration done:

TCP IP Port: Adress: 192.168.1.12 Port: 502

Modbus Compatible Device: Selected 'Open Modbus TCP'

Analog Input: IO was configured the adress as being 19000

The modbus address are found here:

https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=&ved=2ahUKEwjDvaOPyIvqAhXbGbkGHTwUCz4QFjACegQIBBAC&url=https%3A%2F%2Fwww.janitza.com%2Fmanuals.html%3Ffile%3Dfiles%2Fdownload%2Fmanuals%2Fcurrent%2FUMG508%2Fjanitza-mal-umg508-en.pdf&usg=AOvVaw1pHCaa7R3VxJmjeOitdqrn

Could you help me to stablish this communication?

We are testing the VT Scada Light. I am trying to connect it with a energy measurement system using Modbus over TCP/IP directly from PC. I created the tag using 'TCP IP Port' -> 'Modbus Compatible Device' -> 'Analog Input' and didn´t get the communication. Followed the basic configuration done: TCP IP Port: Adress: 192.168.1.12 Port: 502 Modbus Compatible Device: Selected 'Open Modbus TCP' Analog Input: IO was configured the adress as being 19000 The modbus address are found here: https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=&ved=2ahUKEwjDvaOPyIvqAhXbGbkGHTwUCz4QFjACegQIBBAC&url=https%3A%2F%2Fwww.janitza.com%2Fmanuals.html%3Ffile%3Dfiles%2Fdownload%2Fmanuals%2Fcurrent%2FUMG508%2Fjanitza-mal-umg508-en.pdf&usg=AOvVaw1pHCaa7R3VxJmjeOitdqrn Could you help me to stablish this communication?

Confirm you can telnet to the device on port 502 before troubleshooting VTScada if you can't get data at all.

Check address 190000, 19001 instead of 19000, too.
Check data type and attach the correct suffix if data is not correct. For floats, you may have to toggle the byte order flags on the driver

Edit: As Victor said these are 4x registers, so addresses should be offset by 40000/400000/40001/400001 depending on implementation.

Confirm you can telnet to the device on port 502 before troubleshooting VTScada if you can't get data at all. Check address 190000, 19001 instead of 19000, too. Check data type and attach the correct suffix if data is not correct. For floats, you may have to toggle the byte order flags on the driver Edit: As Victor said these are 4x registers, so addresses should be offset by 40000/400000/40001/400001 depending on implementation.
edited Jun 19 at 6:48 pm

Hi, is me again - Leonardo. I had to create a new profile due problems with the login.

I tried the changes suggested but keep not working. Would it be possible schedule a meeting using Zoom to try to ajust this point?

Thanks in advance!

Hi, is me again - Leonardo. I had to create a new profile due problems with the login. I tried the changes suggested but keep not working. Would it be possible schedule a meeting using Zoom to try to ajust this point? Thanks in advance!

I tried the modbus communictation using the modbus Diagnostic from Device Manufacture and it´s working properly.

5ef0b1d1123fb

I tried the modbus communictation using the modbus Diagnostic from Device Manufacture and it´s working properly. ![5ef0b1d1123fb](serve/attachment&path=5ef0b1d1123fb)

Using 419000/Float the communication is confirmed but the data is not working. I change 419001 and other but keep not working... I have no more ideas of what could be changed... Are there some suggestion?

Tks.

Using 419000/Float the communication is confirmed but the data is not working. I change 419001 and other but keep not working... I have no more ideas of what could be changed... Are there some suggestion? Tks.

Please check to verify your addresses are correct. Check to see if 419000 should be 41900 etc as most Modbus registers are between 0 and 49999.

Also, we do have technical sales staff available and you can look for a technical contact in your area by visiting https://www.vtscada.com/contact-us/ . If you are reaching out to us from outside of North America, then Pat Cooke is your best point of contact for a webinar.

Also note that VTScada will only show a Modbus connection once a register is read, even if the port tag and driver are configured correctly.

Please check to verify your addresses are correct. Check to see if 419000 should be 41900 etc as most Modbus registers are between 0 and 49999. Also, we do have technical sales staff available and you can look for a technical contact in your area by visiting https://www.vtscada.com/contact-us/ . If you are reaching out to us from outside of North America, then Pat Cooke is your best point of contact for a webinar. Also note that VTScada will only show a Modbus connection once a register is read, even if the port tag and driver are configured correctly.

Trihedral Engineering Ltd.

If you're already see some data, you might want to try reversing the byte order on the Modbus Driver tag 5ef3628370fb0

If you're already see some data, you might want to try reversing the byte order on the Modbus Driver tag ![5ef3628370fb0](serve/attachment&path=5ef3628370fb0)

Hi guys,

I have tried all the tips. I have not indentify where I define the format of the data (hex, bin... ) maybe could be here the problem...

Another question is:

In modbus device configuration I have virtual IO configuration. I set it up as being 0. And in the configuration of analog input i set it up the IO setting tab as being 419000 and some data is read. If I change for 41317 (another adress for the same information) no data is reading. But if I tried using the Janitza Modbus reader... I receive the data again in the correct way.

So the only thing that come to my mind is the format of the data...

tks.

Leonardo

Hi guys, I have tried all the tips. I have not indentify where I define the format of the data (hex, bin... ) maybe could be here the problem... Another question is: In modbus device configuration I have virtual IO configuration. I set it up as being 0. And in the configuration of analog input i set it up the IO setting tab as being 419000 and some data is read. If I change for 41317 (another adress for the same information) no data is reading. But if I tried using the Janitza Modbus reader... I receive the data again in the correct way. So the only thing that come to my mind is the format of the data... tks. Leonardo

What value are you seeing in the tag browser for the TCP tag? And for the modbus tag? VTScada is a modbus master. I see that the device can be configured for a master and a slave. Can you ensure it is configured as a slave.

Do you have Wireshark available? Is it possible to get captures when VTScada is connected and again when the Janitza software is connected? Along with your changeset please?

What value are you seeing in the tag browser for the TCP tag? And for the modbus tag? VTScada is a modbus master. I see that the device can be configured for a master and a slave. Can you ensure it is configured as a slave. Do you have Wireshark available? Is it possible to get captures when VTScada is connected and again when the Janitza software is connected? Along with your changeset please?

Doug Spurrell

Hi Dougs,

My device is configured as slave. And I get the information from VTScada and Janitza comunication at the same time...

5efb85013ba98
5efb8501a7108

As you can see from Janitza comunication tester is working....

I´m not familiarized with Wireshark.

Tks

Hi Dougs, My device is configured as slave. And I get the information from VTScada and Janitza comunication at the same time... ![5efb85013ba98](serve/attachment&path=5efb85013ba98) ![5efb8501a7108](serve/attachment&path=5efb8501a7108) As you can see from Janitza comunication tester is working.... I´m not familiarized with Wireshark. Tks

have you tried 419001/FLOAT ?
Looks like it might be 0-based in the manual
VTScada by default uses 1-based registers

have you tried **419001/FLOAT** ? Looks like it might be 0-based in the manual VTScada by default uses 1-based registers

I had already tried and it made me think about the data format.

Look below...

5efcfdb537681

tks

I had already tried and it made me think about the data format. Look below... ![5efcfdb537681](serve/attachment&path=5efcfdb537681) tks

what about 319000/Float and 319001/Float?

and since there seems to be some data, have you try checking the Reverse IEEE checkboxes on your Modbus Compatible Device tag?

what about **319000/Float** and **319001/Float**? and since there seems to be some data, have you try checking the **Reverse IEEE** checkboxes on your Modbus Compatible Device tag?
edited Jul 1 at 10:24 pm

Try all 4 combinations of the IEEE byte order on the Modbus driver on the same address you are reading. That very much looks like a word order error.

Try all 4 combinations of the IEEE byte order on the Modbus driver on the same address you are reading. That very much looks like a word order error.
162
15
6
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft