Support Forums
BACnet Driver

Hello,

I am having a really difficult time getting the BACnet Driver to make a connection to an MGate 5217 from MOXA which is a BACnet to Modbus gateway. I am very new to VTScada light but I was able to get the Modbus driver on VTScada to work so I know I am close.

With the BACnet driver. I am not sure if the IP address of the UDP port should be the loopback IP address of (127.0.0.1) or if it should be the IP Address of the MGate 5217 which is a (192.168.0.52). I should mention that everything is local (PC running VTS:192.168.0.44) so on the BACnet driver I am choosing the network type to be "Local Network" . However, I am not sure if I should be using "Foreign Network" due to the type of gateway I am using. I am used to using BACnet simulators such as YABE which has the auto discovery object option which is why this has been more difficult for me.

Hello, I am having a really difficult time getting the BACnet Driver to make a connection to an MGate 5217 from MOXA which is a BACnet to Modbus gateway. I am very new to VTScada light but I was able to get the Modbus driver on VTScada to work so I know I am close. With the BACnet driver. I am not sure if the IP address of the UDP port should be the loopback IP address of (127.0.0.1) or if it should be the IP Address of the MGate 5217 which is a (192.168.0.52). I should mention that everything is local (PC running VTS:192.168.0.44) so on the BACnet driver I am choosing the network type to be "Local Network" . However, I am not sure if I should be using "Foreign Network" due to the type of gateway I am using. I am used to using BACnet simulators such as YABE which has the auto discovery object option which is why this has been more difficult for me.

Hey Everyone,

I have communication going between VTScada and my BACnet server but I keep getting an error code 31 of unknown object. I only have one object at the moment which is an Analog input at instance 0 so I used an I/O and calcualations tag and setup the data type to be Analog. Under the I/O field I chose the Read Address to be an Object type of "Analog Input" and the Instance Number of 0 and for the propterty it is the default of Present_Value. This is the exact same setup as my bacnet server but I continue to get the error code 31 unknown-object. Any ideas what I may be entering wrong? I am using wireshark to confirm the error code I am receiving.

I was also wondering if there was a way to setup multiple reads at once? For example, AI0, AI1, AI2 being ready with one command or do I have to add each tag individually?

I appreciate all of the help, I have been stuck with the first issue for quite some days now.

Hey Everyone, I have communication going between VTScada and my BACnet server but I keep getting an error code 31 of unknown object. I only have one object at the moment which is an Analog input at instance 0 so I used an I/O and calcualations tag and setup the data type to be Analog. Under the I/O field I chose the Read Address to be an Object type of "Analog Input" and the Instance Number of 0 and for the propterty it is the default of Present_Value. This is the exact same setup as my bacnet server but I continue to get the error code 31 unknown-object. Any ideas what I may be entering wrong? I am using wireshark to confirm the error code I am receiving. I was also wondering if there was a way to setup multiple reads at once? For example, AI0, AI1, AI2 being ready with one command or do I have to add each tag individually? I appreciate all of the help, I have been stuck with the first issue for quite some days now.

I have resolved the error code of 31 by changing the BACnet driver from Local network to be Foreign Network. When taking a wireshark capture I can see the correct values that I should be reading within VTScada but for some reason I keep getting a value of 273 for the BACnet driver. I looked into the BACnet error codes and it states the following:
273 0x111 Invalid Header Information

I am not sure how I can be receiving the proper value within wireshark but still be getting this error code on VTScada. A side by side wireshark comparison was done with VTScada and another BACnet simulator called YABE and they are identical which is why I don't understand what can be giving me this error.

Has anyone received this code before and have any idea what needs to be changed? Any help is greatly appreciated

I have resolved the error code of 31 by changing the BACnet driver from Local network to be Foreign Network. When taking a wireshark capture I can see the correct values that I should be reading within VTScada but for some reason I keep getting a value of 273 for the BACnet driver. I looked into the BACnet error codes and it states the following: 273 0x111 Invalid Header Information I am not sure how I can be receiving the proper value within wireshark but still be getting this error code on VTScada. A side by side wireshark comparison was done with VTScada and another BACnet simulator called YABE and they are identical which is why I don't understand what can be giving me this error. Has anyone received this code before and have any idea what needs to be changed? Any help is greatly appreciated
38
2
1
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft